70s Community Header Image

In Dire Straits

Home PageForums70s MusicIn Dire Straits


This topic has 3 voices, contains 2 replies, and was last updated by  Rennie 10 years ago.

Viewing 3 posts - 1 through 3 (of 3 total)
Author Posts
Author Posts
January 1, 2013 at 5:16 pm #545

Seventies Man

I had an evening of whiskey and Dire Straits the other night. I loved to go back to the Knopfler brothers and listen to some of the classic music they produced- Brothers In Arms, being one of them.
Of cours ethat was 1985, but there 1978 album called Dire Straits was a great entrance for the group.

The most famous song was of course Sultans Of Swing from January 1979. I did not know that it was release in May 1978 and bummed out! Thank goodness for a Radio London DJ picking it up and making Dire Straits the success it deserved to have.

January 2, 2013 at 10:47 am #555


Never really like Sultans of Swing. Brothers in Arms was GREAT

January 3, 2013 at 9:29 pm #558


Always loved industrial disease …… One lyric goes
Two men say their Jesus , one of them must be wrong

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

1970s Community Forum

This is the place to share the memories of those great by gone days and help each other nudge those hidden gems out of the darkest recesses of your minds. Believe me there's a lot of them. Since I started this nostalgia site 7 years ago so many great memories have been cajoled out of my ageing grey cells by my forum friends that would never ever have seen the light of day again. So join in the fun and see what great memories we can help you recall.

Join the Discussion

Register now & join in the discussions, this will allow you to add your own comments, memories, photographs and stories to our ever growing website dedicated to the Seventies. Simply sign up using your Facebook, Twitter, Linked In or Google+ Account

Your API connection setting not working. try to change setting from module option or check your php.ini setting for (cURL support = enabled OR allow_url_fopen = On)